r1 has dlci 102 towards r2 and 103 towards r3.
r2 has dlci 201 towards r1.
r3 has dlci 301 towards r1.
Configure EIGRP to redistribute subnet on FastEthernet0/0.
Don't use dynamic mapping. Use main interfaces.
On r1:
!
interface FastEthernet0/0
ip address 150.123.1.1 255.255.255.0
!
interface Serial1/0
ip address 150.123.0.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 150.123.0.2 102 broadcast
frame-relay map ip 150.123.0.3 103 broadcast
no frame-relay inverse-arp
no clns route-cache
!
router eigrp 1
redistribute connected metric 1 0 0 1 1 route-map CONNECTED->EIGRP
network 150.123.0.1 0.0.0.0
no auto-summary
eigrp router-id 150.1.1.1
!
route-map CONNECTED->EIGRP permit 10
match interface FastEthernet0/0
!
On r2:
!
interface FastEthernet0/0
ip address 150.123.2.2 255.255.255.0
!
interface Serial1/0
ip address 150.123.0.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 150.123.0.1 201 broadcast
frame-relay map ip 150.123.0.3 201
no frame-relay inverse-arp
no clns route-cache
!
router eigrp 1
redistribute connected metric 1 0 0 1 1 route-map CONNECTED->EIGRP
network 150.123.0.2 0.0.0.0
no auto-summary
eigrp router-id 150.2.2.2
!
route-map CONNECTED->EIGRP permit 10
match interface FastEthernet0/0
!
On r3:
!
interface FastEthernet0/0
ip address 150.123.3.3 255.255.255.0
!
interface Serial1/0
ip address 150.123.0.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 150.123.0.1 301 broadcast
frame-relay map ip 150.123.0.2 301
no frame-relay inverse-arp
no clns route-cache
!
router eigrp 1
redistribute connected metric 1 0 0 1 1 route-map CONNECTED->EIGRP
network 150.123.0.3 0.0.0.0
no auto-summary
eigrp router-id 150.3.3.3
!
route-map CONNECTED->EIGRP permit 10
match interface FastEthernet0/0
!
Check the routing table on r1:
r1#show ip route eigrp
150.123.0.0/24 is subnetted, 4 subnets
D EX 150.123.3.0 [170/2560512000] via 150.123.0.3, 00:06:14, Serial1/0
D EX 150.123.2.0 [170/2560512000] via 150.123.0.2, 00:05:16, Serial1/0
Check the routing table on r2:
r2#sh ip route eigrp
150.123.0.0/24 is subnetted, 3 subnets
D EX 150.123.1.0 [170/2560512000] via 150.123.0.1, 00:05:36, Serial1/0
Check the routing table on r3:
r3#sh ip route eigrp 150.123.0.0/24 is subnetted, 3 subnets
D EX 150.123.1.0 [170/2560512000] via 150.123.0.1, 00:06:42, Serial1/0
Where is the route to 150.123.2.0/24 on r3 ?
Where is the route to 150.123.3.0/24 on r2 ?
This is a problem due to split-horizon, but on main interface, split-horizon is disabled by default:
r1#show ip interface S1/0
Serial1/0 is up, line protocol is up
Internet address is 150.123.0.1/24
Broadcast address is 255.255.255.255
...
Multicast reserved groups joined: 224.0.0.10
...
Split horizon is disabled
...
So, what is the problem ?
Solution
Disable split-horizon for the eigrp as...
r1(config)#interface serial1/0
r1(config-if)#no ip split-horizon eigrp 1
r1(config-if)#end
Note: eigrp neighbor restart.
Result
r3#show ip route eigrp
150.123.0.0/24 is subnetted, 4 subnets
D EX 150.123.1.0 [170/2560512000] via 150.123.0.1, 00:00:04, Serial1/0
D EX 150.123.2.0 [170/2561024000] via 150.123.0.1, 00:00:03, Serial1/0
r2#show ip route eigrp
150.123.0.0/24 is subnetted, 4 subnets
D EX 150.123.1.0 [170/2560512000] via 150.123.0.1, 00:01:01, Serial1/0
D EX 150.123.3.0 [170/2561024000] via 150.123.0.1, 00:00:02, Serial1/0
It works...
r2#ping 150.123.3.3 source 150.123.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.123.3.3, timeout is 2 seconds:
Packet sent with a source address of 150.123.2.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/50/76 ms
r2#