21 déc. 2009

OSPF & NBMA Networks Part 2: broadcast

NBMA Networks are Frame-Relay, ATM & X.25 networks.
Multiple devices are attached but are non-broadcast.




The network type is set to 'broadcast'.
The DLCI is treaten as a broadcast link, a DR/BDR election occurs.
OSPF packets are multicast.

On R3:
!
interface Serial1/0.3456 multipoint
ip address 100.3.0.3 255.255.255.0
ip ospf network broadcast
ip ospf priority 10
frame-relay map ip 100.3.0.4 304 broadcast
frame-relay map ip 100.3.0.5 305 broadcast
frame-relay map ip 100.3.0.6 306 broadcast
!
router ospf 1
router-id 100.0.3.1
log-adjacency-changes
redistribute connected subnets
network 100.3.0.0 0.0.0.255 area 0
!

On R4:
!
interface Serial1/0.3456 multipoint
ip address 100.3.0.4 255.255.255.0
ip ospf network broadcast
ip ospf priority 0
frame-relay map ip 100.3.0.5 403
frame-relay map ip 100.3.0.6 403
frame-relay map ip 100.3.0.3 403 broadcast
!
router ospf 1
router-id 100.0.4.1
log-adjacency-changes
redistribute connected subnets
network 100.3.0.0 0.0.0.255 area 0
!

R3#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
100.0.4.1 0 FULL/DROTHER 00:00:31 100.3.0.4 Serial1/0.3456
100.0.5.1 0 FULL/DROTHER 00:00:39 100.3.0.5 Serial1/0.3456
100.0.6.1 0 FULL/DROTHER 00:00:35 100.3.0.6 Serial1/0.3456
R3#

Messages are multicast:
*Dec 21 16:49:36.231: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0.3456 from 100.3.0.3

OSPF & NBMA Networks Part 1: point-to-multipoint

OSPF Network Type: point-to-multipoint
NBMA Networks are Frame-Relay, ATM & X.25 networks.
Multiple devices are attached but are non-broadcast.





Question
Configure OSPF on R3, R4, R5 and R6 such as no DR election occurs.




Set the network type to 'point-to-multipoint'.
The DLCI is treaten as point-to-point link, so no DR/BDR election occurs.
OSPF packets are still multicast.


On R3:
!
interface Serial1/0.3456 multipoint
 ip address 100.3.0.3 255.255.255.0
 ip ospf network point-to-multipoint
 frame-relay interface-dlci 304 
 frame-relay interface-dlci 305
 frame-relay interface-dlci 306
!
router ospf 1
 router-id 100.1.3.1
 log-adjacency-changes
 network 100.3.0.3 0.0.0.0 area 0
!


On R4:
!
interface Serial1/0.3456 multipoint
 ip address 100.3.0.4 255.255.255.0
 ip ospf network point-to-multipoint
 frame-relay interface-dlci 403
!
router ospf 1
 router-id 100.1.3.1
 log-adjacency-changes
 network 100.3.0.4 0.0.0.0 area 0
!
and so on for R5 and R6.


No DR/BDR election occurs:
R3#show ip ospf neighbor


Neighbor ID Pri State Dead Time Address Interface
100.1.5.9 0 FULL/ - 00:01:37 100.3.0.5 Serial1/0.3456
100.1.4.1 0 FULL/ - 00:01:57 100.3.0.4 Serial1/0.3456
100.1.6.1 0 FULL/ - 00:01:56 100.3.0.6 Serial1/0.3456

NTP - ACL

NTP - Network Time Protocol Packet types: -  Control messages : don't bother with this. -  NTP request/update messages: used for time sy...