RIPv1 and RIPv2 on the same router
R1 is the HUB, R2 and R3 are the SPOKES.
R1 and r2 are RIPv2, r3 is RIPv1.
R1 and r2 are RIPv2, r3 is RIPv1.
As the R1 is using a single interface
to connect to R2 and R3, it must send/receive v1 and v2 messages.
R1 :
!
interface Serial1/0.123 multipoint
ip address 150.123.0.1 255.255.255.0
ip rip send version 1 2
ip rip receive version 1 2
ip rip authentication mode md5
ip rip authentication key-chain CCIE
no ip split-horizon
frame-relay map ip 150.123.0.2 102 broadcast
frame-relay map ip 150.123.0.3 103 broadcast
no frame-relay inverse-arp
!
router rip
version 2
redistribute connected route-map
CONNECTED->RIP
network 150.123.0.0
no auto-summary
!
route-map CONNECTED->RIP permit 10
match interface FastEthernet0/0
!
R2 :
!
interface Serial1/0
ip address 150.123.0.2 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain CCIEr2
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 150.123.0.3 201
frame-relay map ip 150.123.0.1 201 broadcast
no frame-relay inverse-arp
no clns route-cache
end
!
router rip
version 2
redistribute connected route-map
CONNECTED->RIP
network 150.123.0.0
no auto-summary
!
route-map CONNECTED->RIP permit 10
match interface FastEthernet0/0
!
R3 is configured in RIPv1 :
!
interface Serial1/0
ip address 150.123.0.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 150.123.0.2 301
frame-relay map ip 150.123.0.1 301 broadcast
no frame-relay inverse-arp
no clns route-cache
!
router rip
redistribute connected route-map
CONNECTED->RIP
network 150.123.0.0
!
route-map CONNECTED->RIP permit 10
match interface FastEthernet0/0
!
Note that there is no need to configure any authentication on R3 even if it is enabled on R1. That is because R3 works with RIPv1.